Install Simple forum Install Simple forum
 RegisterRegister ProfileProfile  Log in to check your private messagesLog in to check your private messages  Log inLog in
Installing on Windows 7
Author Message
lorenzo



Joined: 13 Oct 2010
Posts: 4

Posted: Sat Nov 20, 2010 4:20 pm

Reply with quote

I have a problem.
I just started using InstallSimple for my software, and just put out my first beta using it.
I use xp for my development system.
I tried installing my software on a fresh windows 7 system, but it hangs when installing the first file. the progress bar stays empty.
Are there any known problems or anything I can try to fix this? it is a xen virtual machine, but I doubt that would affect an installer.
I will try reinstalling windows fresh again.

After I cancel the installer, I get this message:

http://installsimple.com/forum/images/programcompatibilityassistant.gif

edit: I just noticed in the screenshot I posted, it says try running the program as administrator.
I tried that and it installed ok. grr windows. probably nothing I can do to improve this?
Maybe you can add a check and error message if it needs to be run as administrator
View user's profile Send private message
Sergey Ivanov



Joined: 27 Jan 2010
Posts: 2

Posted: Sun Nov 21, 2010 6:14 pm

Reply with quote

Dear Lorenzo,
Thank you for your bug report...

If your installation require the administrator rights,
you can check the "Require administrator rights" option

http://installsimple.com/forum/images/screen.gif

In the every release we improve and optimize the InstallSimple algorithms.
The last release include above the 80 small improvements.

We will improve the InstallSimple and further, certainly will use your wishes...
If you have any questions, please let us know.

Best regards,
Sergey Ivanov, manager
View user's profile Send private message Send e-mail
lorenzo



Joined: 13 Oct 2010
Posts: 4

Posted: Sun Nov 21, 2010 7:52 pm

Reply with quote

Sergey Ivanov wrote:
If your installation require the administrator rights,
you can check the "Require administrator rights" option

Gave it a few tries, but it doesn't seem to change anything.
It still runs the installer wizard then locks installing.
I'm logged in under the default user account that's created after windows installs.
It's marked as administrator, not just standard user.
View user's profile Send private message
Sergey Ivanov



Joined: 27 Jan 2010
Posts: 2

Posted: Sun Nov 21, 2010 8:17 pm

Reply with quote

Dear Lorenzo,

The Windows 7 in some rare cases, locks the InstallSimple installing...
This problem depends on User Account control settings.
Shortly this problem will be fixed.
Thank you!

http://installsimple.com/forum/images/screen2.gif
View user's profile Send private message Send e-mail
lorenzo



Joined: 13 Oct 2010
Posts: 4

Posted: Mon Nov 22, 2010 1:57 am

Reply with quote

ok, thank you. now I know how to explain the problem
View user's profile Send private message
Display posts from previous:   
Jump to:   
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum